1360:奇怪的电梯(lift)

news/2024/11/29 4:47:20/
 

【题目描述】

大楼的每一层楼都可以停电梯,而且第i层楼(1≤iN)上有一个数字Ki(0≤=Ki≤=N)。电梯只有四个按钮:开,关,上,下。上下的层数等于当前楼层上的那个数字。当然,如果不能满足要求,相应的按钮就会失灵。例如:3 3 1 2 5代表了KiK1=3,K2=3,……),从一楼开始。在一楼,按“上”可以到4楼,按“下”是不起作用的,因为没有−2楼。那么,从A楼到B楼至少要按几次按钮呢?

【输入】

共有二行,第一行为三个用空格隔开的正整数,表示N,A,B(1≤N≤200,1≤A,BN),第二行为N个用空格隔开的正整数,表示Ki

【输出】

一行,即最少按键次数,若无法到达,则输出−1。

【输入样例】

5 1 5
3 3 1 2 5

【输出样例】

3
#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
#include <set>
#include <queue>
#include <stack>
#define sf(a) scanf("%d\n",&a)
#define pf(a) printf("%.2lf\n",a)
#define pi acos(-1.0)
#define E 1e-8
#define ms(a) memset(a,0,sizeof a)
#define rep(a,b,c) for(int a=b;a<=c;a++)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int inf=0x3f3f3f3f;
const int idata=200+5;struct node
{int floor;int count;
};
//ll i,j,k;
int judge,flag;
int step[idata];
bool vis[idata];
int n,m,t,ans;
int maxx=0,minn=inf;
int cnt,len,sum;
//map<ll,int>pre[2];
string s;
//priority_queue<ll, vector<ll>,less<ll> >q;
queue<node>q;
const int delta[4][2]={{1,0},{0,1},{-1,0},{0,-1}};int main()
{int start,last;while(cin>>n>>start>>last){rep(i,1,n){cin>>step[i];}node button,temp;button.floor=start;button.count=0;vis[start]=1;q.push(button);while(!q.empty()){temp=q.front();q.pop();if(temp.floor==last) break;int x=temp.floor+step[temp.floor];if(x<=n && !vis[x]){button.floor=x;button.count=temp.count+1;q.push(button);vis[x]=1;}x=temp.floor-step[temp.floor];if(x>=1 && !vis[x]){button.floor=x;button.count=temp.count+1;q.push(button);vis[x]=1;}}if(temp.floor==last) cout<<temp.count<<endl;else puts("-1");}return 0;
}

 


http://www.ppmy.cn/news/215647.html

相关文章

洛谷CF1360E 多边形

洛谷CF1360E 多边形 题目标签标签难度 思路分析思路一 错因分析AC代码 题目标签 CF1360E 标签 模拟 难度 普及/提高- 思路分析 思路一 时间复杂度 O ( n 2 t ) O(n^2t) O(n2t) 说实在&#xff0c;这一题其实很简单。一道纯模拟题。我们先来分析一下题目&#xff1a;“…

1360. 日期之间隔几天

题目描述 请你编写一个程序来计算两个日期之间隔了多少天。日期以字符串形式给出&#xff0c;格式为 YYYY-MM-DD&#xff0c;如示例所示。示例 1&#xff1a;输入&#xff1a;date1 "2019-06-29", date2 "2019-06-30" 输出&#xff1a;1 示例 2&#xf…

一本通1360 奇怪的电梯

1360&#xff1a;奇怪的电梯(lift) 时间限制: 1000 ms 内存限制: 65536 KB 提交数: 4790 通过数: 2047 【题目描述】 大楼的每一层楼都可以停电梯&#xff0c;而且第i层楼&#xff08;1≤i≤N&#xff09;&#xff08;1≤i≤N&#xff09; 上有一个数字Ki(0≤Ki≤…

LeetCode 1360 - 1363

时间之间隔几天 两个日期之间没有大小关系&#xff0c;可能第 1 个日期大&#xff0c;可能第 2 个日期大&#xff0c;需要同时处理两种情况 1971.1.1 → date1 一共过了 days1 天 1971.1.1 → date2 一共过了 days2 天 | day1 - day2 | 就是答案&#xff0c;因为不知道哪个…

[Codeforces Round #644 (div3)]1360

1360A - Minimal Square[思维] 1360B - Honest Coach[思维] 1360C -Similar Pairs[思维] 1360D - Buying Shovels[思维] 1360E - Polygon[思维] 1360F - Spy-string[暴力] 1360G - A/B Matrix[构造] 1360H - Binary Median[思维] 这场都是思维题&#xff0c;题目就不贴过来了 感…

cf1360G

1360G 1900 题意&#xff1a;对一个长度为m高度为n的全为零二维数组进行操作也就是ar[n][m], 令其每列横行1的个数为a,每排纵行的1的个数为b&#xff0c; 如下所示、 该数组的a2&#xff0c;b1&#xff0c;问你是否存在这么一个ar[n][m]数组使得其满足a和b的要求&#xff0c;…

厦大C语言上机 1360 算日期

1360.算日期 时间限制: 1000 MS 内存限制: 65536 K 提交数: 647 (0 users) 通过数: 286 (279 users) 问题描述 自从收了小明这个徒弟之后&#xff0c;小强的生活就没平静过&#xff0c;小明发扬勤奋好问的精神&#xff0c;总是缠着小强问这问那的。这天&…

ausu-fx80-efi黑苹果10.15.7

因为虚拟机实在太卡了&#xff0c;尝试下了黑苹果&#xff0c;还有一点点的小毛病但是总体我很满意。 这里我分享一下我的笔记本用的EFI。 https://gitee.com/NoCoke/ausu-fx80-g-fx504-ge-efi