#10046. 「一本通 2.2 练习 2」OKR-Periods of Words(内附封面)

news/2024/11/15 1:26:33/

[POI2006] OKR-Periods of Words

题面翻译

对于一个仅含小写字母的字符串 a a a p p p a a a 的前缀且 p ≠ a p\ne a p=a,那么我们称 p p p a a a 的 proper 前缀。

规定字符串 Q Q Q(可以是空串)表示 a a a 的周期,当且仅当 Q Q Q a a a 的 proper 前缀且 a a a Q + Q Q+Q Q+Q 的前缀。

例如 ababab 的一个周期,因为 ababab 的 proper 前缀,且 ababab+ab 的前缀。

求给定字符串所有前缀的最大周期长度之和。

题目描述

A string is a finite sequence of lower-case (non-capital) letters of the English alphabet. Particularly, it may be an empty sequence, i.e. a sequence of 0 letters. By A=BC we denotes that A is a string obtained by concatenation (joining by writing one immediately after another, i.e. without any space, etc.) of the strings B and C (in this order). A string P is a prefix of the string !, if there is a string B, that A=PB. In other words, prefixes of A are the initial fragments of A. In addition, if P!=A and P is not an empty string, we say, that P is a proper prefix of A.

A string Q is a period of Q, if Q is a proper prefix of A and A is a prefix (not necessarily a proper one) of the string QQ. For example, the strings abab and ababab are both periods of the string abababa. The maximum period of a string A is the longest of its periods or the empty string, if A doesn’t have any period. For example, the maximum period of ababab is abab. The maximum period of abc is the empty string.

Task Write a programme that:

reads from the standard input the string’s length and the string itself,calculates the sum of lengths of maximum periods of all its prefixes,writes the result to the standard output.

输入格式

In the first line of the standard input there is one integer k k k ( 1 ≤ k ≤ 1 000 000 1\le k\le 1\ 000\ 000 1k1 000 000) - the length of the string. In the following line a sequence of exactly k k k lower-case letters of the English alphabet is written - the string.

输出格式

In the first and only line of the standard output your programme should write an integer - the sum of lengths of maximum periods of all prefixes of the string given in the input.

样例 #1

样例输入 #1

8
babababa

样例输出 #1

24

数据范围与提示

对于全部数据, 1 < k < 1 0 6 1\lt k\lt 10^6 1<k<106

人话翻译:

给定一个字符串A,求他所有前缀B(包括A=B)的最大周期,周期即B的前缀C最长,C要满足B是CC的字串。实例:
A B A B A B A B 的所有前缀有: − − − − − − − − − 周期为 − − − 长度 ABABABAB的所有前缀有:---------周期为---长度 ABABABAB的所有前缀有:周期为长度
A − − − − − − − − − − − − − − − − − − − − 无 − − − − − 0 A--------------------无-----0 A0
A B − − − − − − − − − − − − − − − − − − − 无 − − − − − 0 AB-------------------无-----0 AB0
A B A − − − − − − − − − − − − − − − − − − A B − − − − − 2 ABA------------------AB-----2 ABAAB2
A B A B − − − − − − − − − − − − − − − − − A B − − − − − 2 ABAB-----------------AB-----2 ABABAB2
A B A B A − − − − − − − − − − − − − − − − A B A B − − − − 4 ABABA----------------ABAB----4 ABABAABAB4
A B A B A B − − − − − − − − − − − − − − − A B A B − − − − 4 ABABAB---------------ABAB----4 ABABABABAB4
A B A B A B A − − − − − − − − − − − − − − A B A B A B − − − 6 ABABABA--------------ABABAB---6 ABABABAABABAB6
A B A B A B A B − − − − − − − − − − − − − A B A B A B − − − 6 ABABABAB-------------ABABAB---6 ABABABABABABAB6
因此输出结果为 2 + 2 + 4 + 4 + 6 + 6 = 24 因此输出结果为2+2+4+4+6+6=24 因此输出结果为2+2+4+4+6+6=24

怎么求这些周期长度呢?KMP的精髓也在此,附图(其中next数组就是之前模板中提到的p数组,含义是相同的)

在这里插入图片描述

明显其中的蓝线是黑线的周期

那么这个题目就变得极其简单了,只需要求出 i − n e x t [ n e x t [ i ] ] i-next[next[i]] inext[next[i]],ans累加即可

很简单就可以得到实现代码:

#include<bits/stdc++.h>
using namespace std;
const int N=1e7+999;
int p[N],n,len,ans=0;
char a[N];
void pre(){//KMP模板int j=0;p[1]=0;for(int i=1;i<n;i++){while(j>0&&a[i+1]!=a[j+1])j=p[j];if(a[i+1]==a[j+1])j++;p[i+1]=j;}
} 
int main(){cin>>n;scanf("%s",a+1);pre();for(int i=1;i<=n;i++){int j=i;while(p[j])j=p[j];ans+=i-j;}cout<<ans;return 0;
} 

但是!这样是不够的,会得到以下结果

在这里插入图片描述

算法原理是肯定没有错的,但是问题在哪?

注意k的范围

对于全部数据, 1 < k < 1 0 6 1\lt k\lt 10^6 1<k<106
那么对于我们在累加的ans可能会超出int的范围

十年OI一场空,不开long long 见祖宗

加上longlong

#include<bits/stdc++.h>
using namespace std;
const int N=1e7+999;
int p[N],n;
long long int ans=0;
char a[N];
void pre(){int j=0;p[1]=0;for(int i=1;i<n;i++){while(j>0&&a[i+1]!=a[j+1])j=p[j];if(a[i+1]==a[j+1])j++;p[i+1]=j;}
} 
int main(){cin>>n;scanf("%s",a+1);pre();for(int i=1;i<=n;i++){int j=i;while(p[j])j=p[j];if(p[i]!=0)p[i]=j; ans+=i-j;}cout<<ans;return 0;
} 

信心十足的交上代码,

在这里插入图片描述

哎?不是,啊?KMP超时了?FFFF

咳,随着数据变大,查找 n e x t [ n e x t [ ] ] next[next[]] next[next[]]的时间就变得难以接受,我们可以通过记忆化的方式更改 n e x t next next数组,原理类似于并查集的优化

实现代码(AC)

#include<bits/stdc++.h>
using namespace std;
const int N=1e7+999;
int p[N],n;
long long int ans=0;
char a[N];
void pre(){int j=0;p[1]=0;for(int i=1;i<n;i++){while(j>0&&a[i+1]!=a[j+1])j=p[j];if(a[i+1]==a[j+1])j++;p[i+1]=j;}
} 
int main(){cin>>n;scanf("%s",a+1);pre();for(int i=1;i<=n;i++){int j=i;while(p[j])j=p[j];if(p[i]!=0)p[i]=j;//记忆化,否则会有TLE。 ans+=i-j;}cout<<ans;return 0;
} 

附封面

请添加图片描述


http://www.ppmy.cn/news/682775.html

相关文章

Web页面实现打印功能

核心的代码&#xff1a; window.print() 具体的实现如下&#xff1a; <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns"http://www.w3.org/199…

Jquery网页打印

今天做项目中&#xff0c;需要用到打印功能&#xff0c;开始的时候用js来调用打印机&#xff0c;之后样式&#xff0c;还有什么的都没有了&#xff0c;之后ie有时候还运行不了&#xff0c;后来就在网上找&#xff0c;之后发现jquery有打印插件&#xff0c;所以就用了&#xff0…

网页打印非常优秀的插件 Print.js

前言&#xff1a;最近需要在网页上打印&#xff0c;网上找了很多&#xff0c;刚开始使用的 lodop打印插件来打印&#xff0c;没有达到理想的要求&#xff0c;它需要下载、区分浏览器的位数来安装、在vue使用时候必须写成内部样式&#xff0c;在笔记本样式失效等问题&#xff0c…

html页面实现打印功能

html页面实现打印功能 可用代码效果截图 之前领导让我写一个html页面&#xff0c;可以进行打印&#xff0c;我上网搜了一下&#xff0c;html页面实现打印功能的博客有很多&#xff0c;这里我就不一一介绍了&#xff0c;直接上干货。 可用代码 <!DOCTYPE html> <html …

前端页面打印功能

1.需求介绍 本项目为vue项目&#xff0c;审批表页面需要添加打印功能&#xff0c;打印区域由3部分组成&#xff08;标题、表格和签名&#xff09; 2.为什么不使用PrintJS 一开始我们使用的是printJS() printDetail() {printJS({printable:printJS-form, //打印区域type:html…

Web打印

布鲁斯李 Web打印 随着10i新版本的发布&#xff0c;在10i的iserver中&#xff0c;内置了一个web打印服务。是指将您在 Web 应用中制作的 Web 内容输出为可打印的文档。那么如何使用该服务&#xff0c;请继续往下看&#xff1a; 执行一次成功的web打印任务&#xff0c;我们需要…

html页面实现打印

html页面实现打印功能 方式一 打印整个html页面方式二 通过获取页面html内容打印 方式一 打印整个html页面 <!DOCTYPE html> <html lang"zh" xmlns:th"http://www.thymeleaf.org" > <head><th:block th:include"include :: hea…

WEB打印-网页打印功能(带分页、可多页打印)

<html> <head> <title>Web打印</title> <meta http-equiv"Content-Type" content"text/html; charsetgb2312"> <!--mediaprint 这个属性可以在打印时有效--> <style mediaprint> .Noprint{display:…