1013 Battle Over Cities(34行代码+详细注释)

news/2024/11/8 15:14:15/

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=1006;
int p[N];
struct edge{
    int a,b;
}e[N*N];//N个点至多有N*(N-1)/2条边
int find(int a){//并查集的经典操作 
    if(p[a]!=a)p[a]=find(p[a]);
    return p[a];
}
int main(){
    int n,m,k;
    cin>>n>>m>>k;
    for(int i=0;i<m;i++)cin>>e[i].a>>e[i].b;//输入边 
    while(k--){
        int node;
        cin>>node;
        int cnt=n-1;//初始连通块个数为n-1 
        for(int i=1;i<=n;i++)p[i]=i;//初始化并查集 
        for(int i=0;i<m;i++){//遍历m条边 
            int a=e[i].a,b=e[i].b;//获取边的端点 
            if(a!=node&&b!=node){//若端点都不是要删除的那个点 
                int pa=find(a),pb=find(b);//找到端点的祖先 
                if(pa!=pb){//若不是同个并查集的 
                    p[pa]=pb;//将两个并查集合并,写p[pb]=pa也可 
                    cnt--;//连通块个数-1 
                }
            }    
        }
        cout<<cnt-1<<endl;//cnt个连通块至少需要连接cnt-1条边才能互通 
    }
    return 0;
}


http://www.ppmy.cn/news/83239.html

相关文章

Knowledge-Based Systems latex论文模板

Knowledge-Based Systems 杂志官网https://www.sciencedirect.com/journal/knowledge-based-systems Knowledge-Based Systems 期刊投稿网址 Editorial Manager LetPub 投稿经验和评论&#xff1a; KNOWLEDGE-BASED SYSTEMS 影响因子8.139分&#xff0c;是几区&#xff0c;20…

Tcl-5. format 命令

format 命令和 C 语言中的 printf 和 sprintf 命令类似。它根据一组格式说明来格式化字符 串。此命令不会改变被操作字符串的内容。 [语法]&#xff1a;format spec value1 value2 ... spec 变元包含了格式说明关键词和附加文字。使用%来引入一个关键词&#xff0c;后跟 0 个…

effective c++ 20 传引用代替传值

effective c 20 传引用代替传值 本节&#xff0c;作者开始讨论引用。我们知道c语言已经有了指针&#xff0c;通过指针我们也就可以修改变量本身&#xff0c;而不是修改变量的副本&#xff08;传值&#xff09;&#xff0c; 那么在c中又搞出来个引用&#xff0c; 那么其是不是有…

七、SpringBoot从入门到精通

一、SpringBoot概述 Spring Boot是一个基于Spring框架的开发框架&#xff0c;用于快速构建能够立即运行的生产级Spring应用程序。它是Spring的一个子项目&#xff0c;致力于使Spring开发更加简单、快速和便捷。 二、SpringBoot基础程序 1、点击Spring Initializer&#xff0…

博客系统的后端设计(八) - 实现发布博客功能

文章目录 发布博客1. 约定前后端交互接口2. 服务器代码3. 客户端代码4. 出现的问题 发布博客 在原来的编辑页面点击发布文章按钮&#xff0c;是不会有什么效果的。 这是因为此时还不能实现前后端的交互。 1. 约定前后端交互接口 请求使用 POST&#xff0c;路径是 /blog title这…

大数据治理入门系列:数据血缘关系

血缘关系在人类社会中扮演着重要角色。大多数家庭是基于血缘关系形成的&#xff0c;而家庭作为社会的基本单元&#xff0c;对维系社会稳定发挥着重要关系。其实&#xff0c;数据之间也存在类似的血缘关系。数据从产生、加工、流转&#xff0c;一直到消亡&#xff0c;每个环节必…

【SpringMVC】| SpringMVC拦截器

目录 一&#xff1a;SpringMVC拦截器 1. 拦截器介绍 2. HandlerInterceptor接口分析 3. 自定义拦截器实现权限验证 一&#xff1a;SpringMVC拦截器 SpringMVC 中的 Interceptor 拦截器&#xff0c;它的主要作用是拦截指定的用户请求&#xff0c;并进行相应的预处理与后处理…

Spring Security 如何实现身份认证和授权?

Spring Security 是一个开源的安全框架&#xff0c;提供了基于权限的访问控制、身份认证、安全性事件发布等功能。在 Spring Boot 应用中使用 Spring Security 可以非常方便地实现用户身份认证和授权。 Spring Security 实现身份认证的主要方式是使用认证过滤器链&#xff0c;…