分数 25
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=1006;
int p[N];
struct edge{
int a,b;
}e[N*N];//N个点至多有N*(N-1)/2条边
int find(int a){//并查集的经典操作
if(p[a]!=a)p[a]=find(p[a]);
return p[a];
}
int main(){
int n,m,k;
cin>>n>>m>>k;
for(int i=0;i<m;i++)cin>>e[i].a>>e[i].b;//输入边
while(k--){
int node;
cin>>node;
int cnt=n-1;//初始连通块个数为n-1
for(int i=1;i<=n;i++)p[i]=i;//初始化并查集
for(int i=0;i<m;i++){//遍历m条边
int a=e[i].a,b=e[i].b;//获取边的端点
if(a!=node&&b!=node){//若端点都不是要删除的那个点
int pa=find(a),pb=find(b);//找到端点的祖先
if(pa!=pb){//若不是同个并查集的
p[pa]=pb;//将两个并查集合并,写p[pb]=pa也可
cnt--;//连通块个数-1
}
}
}
cout<<cnt-1<<endl;//cnt个连通块至少需要连接cnt-1条边才能互通
}
return 0;
}