分数 25
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.
Output Specification:
For each of the M queries, print in a line Yes
if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal
; or if it is not a clique at all, print Not a Clique
.
Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=209,INF=0x3f3f3f3f;
int nv,ne;
int g[N][N];
bool st[N];
int main(){
cin>>nv>>ne;
for(int i=0;i<ne;i++){
int a,b;
cin>>a>>b;
g[a][b]=g[b][a]=1;
}
int m;
cin>>m;
for(int i=0;i<m;i++){//m个query
int k;
cin>>k;
vector<int>v;
memset(st,0,sizeof st);
while(k--){//insert序列
int node;
cin>>node;
v.push_back(node);
st[node]=true;
}
int flag=1;//1表示Maximal,0表示Not a Clique
for(int i=0;i<v.size()-1;i++)//若相邻结点没有边则flag置为0
for(int j=i+1;j<v.size();j++)
if(!g[v[i]][v[j]])flag=0;
if(flag){//若相邻结点两两有边
for(int i=1;i<=nv;i++){//将任意一个结点加入看看是否能成新的clique
if(!st[i]){//将没访问过的结点加入
int cnt=0;
for(int j=0;j<v.size();j++){//若新加入的结点与序列有边
if(g[i][v[j]])cnt++;//边数+1
}
if(cnt==v.size()){//若都有边
flag=0;//此时的flag为0表示Not Maximal
break;
}
}
}
if(flag)printf("Yes\n");//若此时flag仍为1
else printf("Not Maximal\n");//若此时flag为0
}
else printf("Not a Clique\n");//若相邻结点不是两两有边
}
return 0;
}