>>> ord('0') 48 | >>> chr(48) '0' |
>>> ord('9') 57 | >>> chr(57) '9' |
>>> ord('A') 65 | >>> chr(65) 'A' |
>>> ord('F') 70 | >>> chr(70) 'F' |
● 巧妙利用字符串的“连接”功能,实现结果输出。
具体到本例代码中,关键是不能将语句 hex=chr(t+ord('0'))+hex 写成 hex=hex+chr(t+ord('0'))。
【输入样例】
123
【输出样例】
7B
【十进制转十六进制 Python 代码】
def toHex(n):hex=""while n!=0:t=n%16if 0<=t<=9:hex=chr(t+ord('0'))+hexelse:hex=chr(t-10+ord('A'))+hexn=n//16print(hex)x=eval(input())
toHex(x)
【十进制转二进制 Python 代码】
def toBin(n):bin=""while n!=0:t=n%2bin=chr(t+ord('0'))+binn=n//2print(bin)x=eval(input())
toBin(x)
【参考文献】
https://blog.csdn.net/hnjzsyjyj/article/details/134089268
https://blog.csdn.net/hnjzsyjyj/article/details/142204614