ZCMU 1074-1079

news/2024/11/7 21:02:16/

1074: 求1+1/2+1/3+...+1/n

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正整数 n(n<=50),计算并输出1+1/2+1/3+...+1/n (保留3 位小数)。

Input

见sample

Output

见sample

Sample Input

2

2

10

Sample Output

1.500

2.929

#include<stdio.h>
int main()
{int repeat,a,i,n,flag;double item,sum;scanf("%d",&repeat);for(a=1;a<=repeat;a++){sum=0;item=1;flag=1;scanf("%d",&n);for(i=1;i<=n;i++){sum=sum+flag*1/item;item=item+1;}printf("%.3f\n",sum);}return 0;
}

 

 

1075: 求n!

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正整数 n (n<=22),计算并输出 n! 。

Input

见sample

Output

见sample

Sample Input

3

1

10

5

Sample Output

1

3628800

120

#include<stdio.h>
double fact(int n);
int main()
{int i,r,n;scanf("%d",&r);if(r>0&&r<10){for(i=1;i<=r;i++){scanf("%d",&n);if(n<=22)printf("%.0f\n",fact(n));   }}return 0;
}
double fact(int n)
{double result,x;result=1;for(x=1;x<=n;x++){result=result*x;        }return result;
}

 

 

1076: 求x 的n 次幂

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正实数x 和1 个正整数 n(n<=10),计算并输出x 的n 次幂(保留2 位小数)。

Input

见sample

Output

见sample

Sample Input

2

1.5  2

2.0  10

Sample Output

2.25

1024.00

 

#include<stdio.h>
#include<math.h>
int main()
{int repeat,i,n;double x,y;scanf("%d",&repeat);for(i=1;i<=repeat;i++){scanf("%lf%d",&x,&n);y=pow(x,n);printf("%.2lf\n",y);}

 

1077: 求1-1/2+1/3-1/4+...

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正整数 n(n<=100),计算并输出1-1/2+1/3-1/4+⋯⋯的前n 项和(保留3 位小数)。

Input

见sample

Output

见sample

Sample Input

1

3

Sample Output

0.833

 

#include<stdio.h>
int main()
{int repeat,a,i,n,flag;double item,sum;scanf("%d",&repeat);for(a=1;a<=repeat;a++){sum=0;item=1;flag=1;scanf("%d",&n);for(i=1;i<=n;i++){sum=sum+flag*1/item;item=item+1;flag=-flag;}printf("%.3f\n",sum);}return 0;
}

 

1078: 求1+1/3+1/5+1/7+...

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正整数 n(n<=100),计算并输出1+1/3+1/5+1/7+⋯⋯的前n 项和(保留3 位小数)。

Input

见sample

Output

见sample

Sample Input

1

3

Sample Output

1.533

 

#include<stdio.h>
int main()
{int repeat,a,i,n,flag;double item,sum;scanf("%d",&repeat);for(a=1;a<=repeat;a++){sum=0;item=1;flag=1;scanf("%d",&n);for(i=1;i<=n;i++){sum=sum+flag*1/(2*item-1);item=item+1;}printf("%.3f\n",sum);}return 0;
}

 

 

 1079: 求1-1/3+1/5-1/7+...

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正实数eps,计算并输出1-1/3+1/5-1/7+⋯⋯,直到最后一项的绝对值小于eps(保留6 位小数,不包括最后一项)。

Input

见sample

Output

见sample

Sample Input

1

1E-4

Sample Output

0.785348

#include<stdio.h>
#include<math.h>
int main()
{int a,repeat;int flag,d,i;double eps,item,pi;scanf("%d",&repeat);for(a=1;a<=repeat;a++){scanf("%lf",&eps);i=1;flag=1;d=1;item=1;pi=0;while(fabs(item)>=eps){pi=pi+item;i++;flag=-flag;d=d+2;item=flag*1.0/d;}printf("%.6lf\n",pi);}return 0;
}


http://www.ppmy.cn/news/147249.html

相关文章

uC/OS-II消息邮箱及其操作

如果要在任务与任务之间传递一个数据&#xff0c;可以用消息邮箱&#xff0c;它的原理是在存储器中建立一个数据缓冲区&#xff0c;然后就以这个缓冲区为中介来实现任务间的数据传递。 一. 消息邮箱的操作 1. 创建消息邮箱 OS_EVENT *OSMboxCreate (void *msg); 调用此函数…

uc7

回顾&#xff1a; 文件相关 - 文件锁、文件相关函数 目录相关函数 - 4个2个读目录的函数 文件锁主要是 读写锁&#xff0c;正确用法是 在调用读函数之前加读锁&#xff0c;在调用写函数之前加写锁&#xff0c;使用完毕后释放锁。如果需要一直等待加锁&#xff0c;可以F_SETLKW实…

uCOS-II总体介绍

第一篇 UCOS介绍 第一篇 UCOS介绍 这个大家都知道。呵呵。考虑到咱们学习的完整性还是在这里唠叨一下。让大家再熟悉一下。高手们忍耐一下吧&#xff01; uC/OS II(Micro Control Operation System Two)是一个可以基于ROM运行的、可裁减的、抢占式、实时多任务内核&#xf…

不仅清晰还要美 OPPO臻美自拍2000万像素再升级

这几天OPPO R11的曝光成为了科技圈的关注焦点。除了已经公布 R11前后置摄像头像素都将升级到2000万&#xff0c;并且使用2000万超清双摄之后&#xff0c;23日OPPO官方微博再次公布了关于R11自拍的信息——2000万臻美自拍&#xff1a;前置背景虚化&#xff0c;自拍更清新。 从OP…

关于uC/OS-II 概述

从应用程序设计的角度来看&#xff0c;uC/OS-II 的任务就是一个用户编写的 C 函数和与之相关 联的一些数据结构而构成的一个实体。把一个大型任务分解成多个小任务﹐然后在计算机中 通过运行这些小任务﹐最终达到完成大任务的目的。 在 uC/OS-II 中&#xff0c;与上述那些小…

UCOSiii 杂谈【1】

【UCOSIII内核学习】 UCOSIII中将已经就绪的任务放到任务就绪表里&#xff1a;优先级映射表和就绪任务列表 在优先级映射表中&#xff0c;bit31代表优先级0&#xff0c;因为这样通过计算前导零CLZ来找到最高优 先级任务。 在就绪任务列表中&#xff0c;通过数组OSRdyList[]来…

Vector Scope

下面以PicoScope 6403E-034为例说明 1.Scope 硬件结构介绍 前面板&#xff1a; 最多支持捕获2路CAN/CANFD/FlexRay总线&#xff0c;或者4路LIN总线 后面板&#xff1a; Scope Bus Probe 300 Mhz 2.Option Scope使用条件 前提条件1&#xff1a;购买CANoe/CANalyzer Option Sc…

UCOS

第一篇 UCOS介绍 第一篇 UCOS介绍 这个大家都知道。呵呵。考虑到咱们学习的完整性还是在这里唠叨一下。让大家再熟悉一下。高手们忍耐一下吧&#xff01; uC/OS II(Micro Control Operation System Two)是一个可以基于ROM运行的、可裁减的、抢占式、实时多任务内核&#xf…