【Python】洛谷P4325 [COCI2006-2007#1] Modulo

news/2024/12/22 15:14:04/

P4325 [COCI2006-2007#1] Modulo

题面翻译

给出 10 10 10 个整数,问这些整数除以 42 42 42 后得到的余数有多少种。

  • 第一个样例的十个结果是 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 10 1,2,3,4,5,6,7,8,9,10 1,2,3,4,5,6,7,8,9,10,有 10 10 10 个不同的结果;
  • 第二个样例结果都是 0 0 0,只有一个不同的结果;
  • 第三个样例余数是 39 , 40 , 41 , 0 , 1 , 2 , 40 , 41 , 0 , 1 39,40,41,0,1,2,40,41,0,1 39,40,41,0,1,2,40,41,0,1,有 0 , 1 , 2 , 39 , 40 , 41 0,1,2,39,40,41 0,1,2,39,40,41 这六个不同的结果。

题目描述

Given two integers A and B, A modulo B is the remainder when dividing A by B. For example, the numbers 7, 14, 27 and 38 become 1, 2, 0 and 2, modulo 3. Write a program that accepts 10 numbers as input and outputs the number of distinct numbers in the input, if the numbers are considered modulo 42.

输入格式

The input will contain 10 non-negative integers, each smaller than 1000, one per line.

输出格式

Output the number of distinct values when considered modulo 42 on a single line.

样例 #1

样例输入 #1

1
2
3
4
5
6
7
8
9
10

样例输出 #1

10

样例 #2

样例输入 #2

42
84
252
420
840
126
42
84
420
126

样例输出 #2

1

样例 #3

样例输入 #3

39
40
41
42
43
44
82
83
84
85

样例输出 #3

6

提示

In the first example, the numbers modulo 42 are 1, 2, 3, 4, 5, 6, 7, 8, 9 and 10.
In the second example all numbers modulo 42 are 0.
In the third example, the numbers modulo 42 are 39, 40, 41, 0, 1, 2, 40, 41, 0 and 1. There are 6 distinct numbers.

代码实现

对于每个输入的整数直接取余,将余数收入集合,最终统计集合长度即可。

print(len(set(int(input()) % 42 for _ in range(10))))

http://www.ppmy.cn/news/1350012.html

相关文章

Vscode SSH使用云服务器访问内网主机

Vscode SSH使用云服务器访问内网主机 云服务器在配置策略中开放使用到的端口号,比如250和251作为使用。 首先在内网主机上使用ssh-copy-id root云服务器公网IP,将内网主机的公钥放到服务器上 这一步必须完成,不然下面的命令无法成功建立隧…

精读《js 模块化发展》

1 引言 如今,Javascript 模块化规范非常方便、自然,但这个新规范仅执行了 2 年,就在 4 年前,js 的模块化还停留在运行时支持,10 年前,通过后端模版定义、注释定义模块依赖。对经历过来的人来说,…

Hadoop:认识MapReduce

MapReduce是一个用于处理大数据集的编程模型和算法框架。其优势在于能够处理大量的数据,通过并行化来加速计算过程。它适用于那些可以分解为多个独立子任务的计算密集型作业,如文本处理、数据分析和大规模数据集的聚合等。然而,MapReduce也有…

从零开始实现消息队列(二)

从零开始实现消息队列 .核心API交换机类型持久化网络通信Connection和Channel 消息应答模块划分 . 核心API 对于Broker来说,要实现以下核心API,通过这些API来实现消息队列的基本功能. 创建队列(queueDeclare)销毁队列(queueDelete)创建交换机(exchangeDeclare)销毁交换机(exc…

QT学习文件操作类 QFile

(一)QFile QFile 是 Qt 框架中用于文件处理的一个类。它提供了读取和写入文件的功能,支持文本和二进制文件。QFile 继承自 QIODevice ,因此它可以像其他 IO 设备一样使用。 (1)主要功能 1. 文件读写…

学习记录691@spring面试之bean的作用域

Spring为Bean定义了5种作用域,分别为Singleton(单例)、Prototype(原型)、Request(请求级别)、Session(会话级别)和Global Session(全局会话)。 S…

mysql、mybatis中SORT

SORT排序 根据数据表sys_series中HOT(int类型)进行升序排列: 原来的数据库中存储: 排序 # 结果是HOT字段为null的所有数据都排在最前面,不为null的数据按升序排列 SELECT * FROM sys_series ORDER BY HOT;# 结果是H…

项目02《游戏-13-开发》Unity3D

基于 项目02《游戏-12-开发》Unity3D , 任务 :宠物系统 及 人物头像血条 首先在主面板MainPanel预制体中新建一个Panel, 命名为PlayerInfo 新建Image,作为头像 新建Slider,作为血条 对Panel组件添加一个水…