1130 Infix Expression(34行代码+超详细注释)

news/2024/10/31 5:24:50/

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=25; 
int n;
string node[N];//记录结点的符号 
int l[N],r[N],exist[N];//记录左右子树的结点号,和出现过的左右孩子 
bool isleaf(int u){//判断是否是叶子结点 
    if(l[u]==-1&&r[u]==-1)return true;
    else return false;
}
string inorder(int u){
    string lchild,rchild;
    if(l[u]!=-1){//有左子树 
        lchild=inorder(l[u]);//记录左子树 
        if(!isleaf(l[u]))lchild="("+lchild+")";//若左子树不是叶结点则加上括号 
    }
    if(r[u]!=-1){//有右子树 
        rchild=inorder(r[u]);//记录右子树 
        if(!isleaf(r[u]))rchild="("+rchild+")";//若右子树不是叶结点则加上括号
    }
    return lchild+node[u]+rchild;//输出左子树+中间结点+右子树 
}
int main(){
    cin>>n;
    for(int i=1;i<=n;i++){//输入 
        cin>>node[i]>>l[i]>>r[i];
        if(l[i]>0)exist[l[i]]=1;//记录出现过的左孩子结点
        if(r[i]>0)exist[r[i]]=1;//记录出现过的右孩子结点 
    }
    int root;
    for(int i=1;i<=n;i++)if(!exist[i])root=i;//没出现的结点就是根结点 
    cout<<inorder(root)<<endl;
    return 0;


http://www.ppmy.cn/news/122204.html

相关文章

【MySQL新手到通关】第一章 数据库概述

文章目录 1. 为什么要使用数据库2. 数据库与数据库管理系统2.1 数据库的相关概念2.2 数据库与数据库管理系统的关系 3. MySQL介绍3.1 概述3.2 关于MySQL 8.03.3 为什么选择 MySQL3.4 Oracle vs MySQL 4. RDBMS 与 非RDBMS4.1 关系型数据库4.1.1 实质4.1.2 优势 4.2 非关系型数据…

夜摘钻石灯

HCY同学又获金牌了&#xff01; 大家都在庆祝&#xff01;叶老师决定给HCY发点奖金以祝贺。不过能得到多少奖金&#xff0c;就要看HCY同学的表现了。 叶老师用n-1条线&#xff0c;把n盏钻石灯连起来&#xff0c;每盏灯在夜幕下都闪烁着一个正整数&#xff0c;这个数就是叶老师要…

柯尼卡美能达打印机c226使用说明_柯尼卡美能达/震旦复印机等各类型号复印机装扫描(SMB扫描)...

柯尼卡美能达/柯美复印机C364e/C454e/C554e/C465e/C307/C367/C360等各类型号复印机装扫描(SMB扫描)

柯尼卡美能达306i提示更换感光鼓定影单元 清零方法

打印量9W9&#xff0c;显示屏提示更换硒鼓或提示更换显影组件和感光鼓组件&#xff0c; 硒鼓和显影组件和感光鼓组件的清零方法。 首先进入机器维修模式方法为&#xff1b;“设置”&#xff0c;左侧的“机器维修”&#xff0c;“计数器”&#xff0c;显示“小键盘”&#xff0…

柯尼卡美能达打印机无法使用ID打印

故障如图&#xff1a; 选择输入方式为【ID&打印】出错&#xff0c;因为认证没有开启。 解决办法&#xff1a; 打印机属性-配置-设备选项-认证&#xff08;改为ON&#xff09;

柯尼卡美能达Konica Minolta bizhub C226 默认管理员密码

亲测 有效 遇到设备&#xff0c;用户说没有改过密码&#xff0c;最后知道是 1234567812345678 柯尼卡美能达Konica Minolta bizhub C226 默认管理员密码 1234567812345678 就是1到8输入两次 网上有查询到6个0或者8个0&#xff0c;或者123456和12345678还有6个1

Win10安装驱动后,无法连接打印机柯尼卡美能达 bizhub 363

Win10系统&#xff0c;在驱动天空安装驱动后&#xff0c;无法连接打印机柯尼卡美能达 bizhub 363 一开始我在控制面板的“设备与打印机”中添加打印机&#xff0c;报错弹框显示&#xff1a;输入码无效。搜索发现以下解决方案&#xff0c;依旧无效 最后&#xff0c;我在设置中的…

柯尼卡美能达Konica Minolta bizhub C7122 打印机驱动

柯尼卡美能达Konica Minolta bizhub C7122 打印机驱动是官方提供的一款一体机&#xff08;打印/扫描&#xff09;驱动&#xff0c;本站收集提供高速下载&#xff0c;用于解决一体机与电脑连接不了&#xff0c;无法正常使用的问题&#xff0c;本动适用于&#xff1a;Windows XP …