POJ 2940 求和

news/2025/1/15 16:00:16/
时间限制: 
1000ms
内存限制:
65536kB
描述
求Sn = a + aa + aaa + … + aa…a 的值(最后一个数中 a 的个数为 n ),其中 a 是一个1~9的数字,例如:

2 + 22 + 222 + 2222 + 22222 (此时 a=2 n=5 )
输入
一行,包括两个整数,第一个为a,第2个为n(1 ≤ a, n ≤ 9),以空格分隔。
输出
一行,Sn的值。
样例输入
2  5
样例输出
24690
(1)、源代码:
#include <iostream>
#include <iomanip>
using namespace std;
 
int main()
{
                 int i, a, n;
                 double mm[9] = {1, 11, 111, 1111, 11111, 111111, 1111111, 11111111, 111111111};
                 double sum = 0;
                cin >> a >> n;
 
                 for (i = 1; i <= n; i++){
                                sum += a * mm[i-1];
                }
                cout <<  fixed << setprecision(0) << sum << endl;
                 return 0;
}
 
(2)、解题思路:略
(3)、可能出错:输出结果,不要科学计数法。

转载于:https://www.cnblogs.com/lydf-2012/archive/2012/05/11/2496601.html


http://www.ppmy.cn/news/304080.html

相关文章

递归与非递归:实现求第n个斐波那契数。实现n^k。输入一个非负整数,返回组成它的数字之和。将参数字符串中的字符反向排列。实现strlen。求n的阶乘。打印一个整数的每一位。

1.递归和非递归分别实现求第n个斐波那契数。 #define _CRT_SECURE_NO_WARNINGS #include<stdio.h> #include<stdlib.h>int fib(int n) {if (n < 2)return 1;elsereturn fib(n - 1) fib(n - 2); }int main() {int n 0;int ret 0;scanf("%d", &…

高精度 hdu 2940 Hex Factorial

直接暴力打表&#xff0c;也可以在代码外打表复制粘贴 #include<cstdio> #include<cstring> #include<cmath> using namespace std; const int BIT 16; struct BIGint{int bit[200];void MEMset(){memset(bit,0,sizeof(bit));bit[1] 1;}void multiply(int …

POJ 2940 Wine Trading in Gergovia [贪心]

Description As you may know from the comic “Asterix and the Chieftain’s Shield”, Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inha…

HDU 2940 Hex Factorial

题目求N&#xff01;中有多少个0 用16进制高精度模拟 想起来一起以前做过的一道题&#xff0c;求末尾有多少个0&#xff0c;不能取0前边的3 4个非零位存下来进行计算&#xff0c;误差太大 #include <iostream> #include <fstream> #include <cstring> usin…

poj 2940 求和

#include <stdio.h>#include <stdlib.h>int main(){ int i,n,a,sum; sum0; scanf("%d%d",&a,&n); for(i0;i<n;i) { suma; aa%1010*a; } printf("%d\n",sum); return 0;} 转载于:https://www…

稳定的LDO芯片推荐

推荐几款稳定性较好的LDO芯片&#xff1a; LM2937&#xff1a;这是一款常用的低噪声LDO&#xff0c;具有良好的稳定性和高效率。 LM2675&#xff1a;这是一款高效率的LDO&#xff0c;特别适用于需要高输出精度的应用。 LM2937-N&#xff1a;这是LM2937的低噪声版本&#xff0c;…

poj2940

简单题 View Code #include <iostream>#include <cstdlib>#include <cstring>#include <cstdio>using namespace std;#define maxn 100005int n, f[maxn];void input(){for (int i 0; i < n; i) scanf("%d", &f[i]);}void w…

百练 2940 求和

题目链接&#xff1a;http://bailian.openjudge.cn/practice/2940 # include <stdio.h>int main() {int Sn,a,a_back,n;int i;scanf("%d%d",&a,&n);a_backa; Sna;for(i1;i<n;i){aa*10a_back;SnSna;}printf("%d\n",Sn); return 0; } &am…