分数 25
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=100009;
int main(){
int add,n,k;
cin>>add>>n>>k;
int data[N],next[N],res[N];//数据,下一地址,结果数组
for(int i=0;i<n;i++){//输入
int a,da,ne;
cin>>a>>da>>ne;
data[a]=da;
next[a]=ne;
}
int cur=0;
while(add!=-1){//从第一个地址开始按序储存
res[cur++]=add;
add=next[add];
}
for(int i=0;i+k<=cur;i+=k)reverse(res+i,res+i+k);//反转
for(int i=0;i<cur-1;i++)printf("%05d %d %05d\n",res[i],data[res[i]],res[i+1]);//五位输出
printf("%05d %d -1\n",res[cur-1],data[res[cur-1]]);//最后一个单独输出
return 0;
}