分数 25
全屏浏览题目
作者 CHEN, Yue
单位 浙江大学
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be −1. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2
代码长度限制
16 KB
时间限制
200 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=100010;
int n,root;
double p,r,res;
vector<int>v[N];//记录各节点的孩子节点
int cnt[N],maxh;//各层节点和最大深度
void dfs(int u,int h){
if(v[u].size()==0){//是叶子结点
res=max(res,p*pow((1+r*1.0/100),h));//更新最大价格
cnt[h]++;//当前层的结点数+1
maxh=max(maxh,h);//记录最深的层数
}
for(int i=0;i<v[u].size();i++){//深搜
dfs(v[u][i],h+1);
}
}
int main(){
cin>>n>>p>>r;
for(int i=0;i<n;i++){//输入
int t;
cin>>t;
if(t==-1)root=i;
else v[t].push_back(i);//t的孩子是i
}
dfs(root,0);//深度遍历找到最深结点的价格和数量
printf("%.2f %d",res,cnt[maxh]);//输出价格和数量
return 0;
}