SCAU数据结构——8610顺序查找

news/2024/11/27 6:22:19/

题目

Description
编写Search_Seq函数,实现在一个无序表ST中采用顺序查找算法查找值为key的元素的算法.
#include"malloc.h" /* malloc()等 */
#include"stdio.h"
#include"stdlib.h"

typedef int ElemType;
typedef struct /*静态查找表的顺序存储结构 */
{
ElemType elem; / 数据元素存储空间基址,建表时按实际长度分配,0号单元留空 /
int length; /
表长度 */
}SSTable;

void Creat_Seq(SSTable &ST,int n)
{ /* 操作结果: 构造一个含n个数据元素的静态顺序查找表ST(数据来自数组r) */
int i,temp;
ST.elem=(ElemType )malloc((n+1) * sizeof(ElemType)); / 动态生成n个数据元素空间(0号单元不用) */
if(!(ST).elem)
{
printf(“ERROR\n”);
exit(0);
} /内存分配失败结束程序/
for(i=1;i<=n;i++)
{
scanf("%d",&temp);
* (ST.elem+i)=temp; /*依次赋值给ST */
}
ST.length=n;
}

int Search_Seq(SSTable &ST,ElemType key)
{ /* 在顺序表ST中顺序查找其关键字等于key的数据元素。若找到,则函数值为 /
/
该元素在表中的位置,否则为0。算法9.1 */

}

main()
{
SSTable ST;
int loc,key;
int n;
scanf("%d",&n);
Creat_Seq(ST,n);
//printf(“Please input the key value:”);
scanf("%d",&key);
loc = Search_Seq(ST,key);
if(loc!=0)
printf(“The element position is %d.\n”,loc);
else
printf(“The element is not exist.\n”);
}

输入格式
第一行:元素个数n
第二行:依次输入n个元素的值
第三行:输入要查找的关键字key的值

输出格式
输出分两种情形:
1.如果key值存在,则输出其在表中的位置x(表位置从1开始),格式为The element position is x.
2.如果key值不存在输出:“The element is not exist.”

输入样例
6
1 3 5 7 9 10
5

输出样例
The element position is 3.

答案

#include"malloc.h" /* malloc()等 */
#include"stdio.h"
#include"stdlib.h"typedef int ElemType;
typedef struct /*静态查找表的顺序存储结构 */
{ElemType *elem; /* 数据元素存储空间基址,建表时按实际长度分配,0号单元留空 */int length; /* 表长度 */
}SSTable;void Creat_Seq(SSTable &ST,int n)
{ /* 操作结果: 构造一个含n个数据元素的静态顺序查找表ST(数据来自数组r) */int i,temp;ST.elem=(ElemType *)malloc((n+1) * sizeof(ElemType)); /* 动态生成n个数据元素空间(0号单元不用) */if(!(ST).elem){printf("ERROR\n");exit(0);} /*内存分配失败结束程序*/for(i=1;i<=n;i++){scanf("%d",&temp);*(ST.elem+i)=temp; /* 依次赋值给ST */}ST.length=n;
}int Search_Seq(SSTable &ST,ElemType key)
{ /* 在顺序表ST中顺序查找其关键字等于key的数据元素。
若找到,则函数值为该元素在表中的位置,否则为0。算法9.1 */int i;ST.elem[0]=key;for(i=ST.length;ST.elem[i]!=key;i--);/*ST.length为元素个数,从后往前找,!记得加分号!,因为当ST.elem[i]==key时循环结束,才会执行下一条语句*/return i;
}main()
{SSTable ST;int loc,key;int n;scanf("%d",&n);Creat_Seq(ST,n);//printf("Please input the key value:");scanf("%d",&key);loc = Search_Seq(ST,key);if(loc!=0)printf("The element position is %d.\n",loc);elseprintf("The element is not exist.\n");
}

期末考死记硬背

 int i;ST.elem[0]=key;for(i=ST.length;ST.elem[i]!=key;i--);/*ST.length为元素个数,从后往前找,!记得加分号!,因为当ST.elem[i]==key时循环结束,才会执行下一条语句*/return i;

http://www.ppmy.cn/news/701795.html

相关文章

msm8610 lcd driver code analysis

---恢复内容开始--- 1 lcd probe The probe sequence is determined by compilation sequence: mdss-mdp3-objs mdp3.o mdp3_dma.o mdp3_ctrl.o #1 mdss-mdp3-objs mdp3_ppp.o mdp3_ppp_hwio.o mdp3_ppp_data.o obj-$(CONFIG_FB_MSM_MDSS) mdss-mdp3.o mdss-mdp-objs…

π110E30 单通道数字隔离器兼容代替Si8610BC-B-IS

π110E30 单通道数字隔离器兼容代替Si8610BC-B-IS 。具有出色的性能特征和可靠性&#xff0c;整体性能优于光耦和基于其他原理的数字隔离器产品。 传输通道间彼此独立&#xff0c;可实现多种传输方向的配置&#xff0c;可实现 1.5kV rms 到 5.0kV rms 隔离耐压等级和 DC 到 600…

SCAU 8610 顺序查找

8610 顺序查找 时间限制:1000MS 代码长度限制:10KB 提交次数:2303 通过次数:1423 题型: 编程题 语言: G;GCC Description 编写Search_Seq函数&#xff0c;实现在一个无序表ST中采用顺序查找算法查找值为key的元素的算法. #include"malloc.h" /* malloc()等 */ #inc…

8610 顺序查找

8610 顺序查找 时间限制:1000MS 代码长度限制:10KB 提交次数:2303 通过次数:1423 题型: 编程题 语言: G;GCC Description 编写Search_Seq函数&#xff0c;实现在一个无序表ST中采用顺序查找算法查找值为key的元素的算法. #include"malloc.h" /* malloc()等 */ #i…

SCAU_OJ 8610 顺序查找

8610 顺序查找 时间限制:1000MS 代码长度限制:10KB 提交次数:2303 通过次数:1423 题型: 编程题 语言: G;GCC Description 编写Search_Seq函数&#xff0c;实现在一个无序表ST中采用顺序查找算法查找值为key的元素的算法. #include"malloc.h" /* malloc()等 */ #i…

QMI8610 QMC5883调试记录

这个芯片复位跟一般芯片不一样&#xff0c;高电平复位&#xff0c;低电平有效。 下面代码接收显示&#xff0c;得到的应该是xyz的磁感强度&#xff0c;还需要自己算法做方位算法校准算法等 qmi8610 //main.cpp #include <unistd.h> #include <stdio.h> #include…

[SAM 代码解读 1] class Sam(nn.Module)

代码解读都写在注释了 目录 sam.py image_encoder.py 重点(Calculate decomposed Relative Positional Embeddings) GitHub 官方代码 sam.py # Copyright (c) Meta Platforms, Inc. and affiliates. # All rights reserved.# This source code is licensed under the lice…

糖糖班趣事之棒棒糖篇

以下故事从东方幼儿园网站上&#xff08;2006年上半年&#xff09;摘录而来&#xff0c;感谢朱老师、干老师对橙橙的辛勤培养和细心记录。 冰糖小苹果最近&#xff0c;橙橙又有了一个新的小名“小苹果”&#xff0c;班上的孩子们都知道她是“小苹果”。一天&#xff0c;吃午饭…