UVA 12506 Shortest Names

news/2024/11/30 20:49:32/

In a strange village, people have very long names. For example: aaaaa, bbb and abababab. You see, it’s very inconvenient to call a person, so people invented a good way: just call a prefix of the names. For example, if you want to call ‘aaaaa’, you can call ‘aaa’, because no other names start with ‘aaa’. However, you can’t call ‘a’, because two people’s names start with ‘a’. The people in the village are smart enough to always call the shortest possible prefix. It is guaranteed that no name is a prefix of another name (as a result, no two names can be equal). If someone in the village wants to call every person (including himself/herself) in the village exactly once, how many characters will he/she use?
Input The first line contains T (T ≤ 10), the number of test cases. Each test case begins with a line of one integer n (1 ≤ n ≤ 1000), the number of people in the village. Each of the following n lines contains a string consisting of lowercase letters, representing the name of a person. The sum of lengths of all the names in a test case does not exceed 1,000,000.
Output
For each test case, print the total number of characters needed.


Sample Input
1 3

aaaaa

bbb

abababab


Sample Output


5

比赛的时候队友做的,,一直没想出来是用字典树,还以为是KMP啥的,后来看了题解才想起来是字典树的一个模板题,还是自己太菜了。。

每遍历一种情况,总和加上遍历的深度,就是所有字符串的前缀。。

感觉寒假的数据结构都白学了。。。T T

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1123456;
char s[N];
int ans;
struct Trie
{int value;Trie *child[30];Trie(){value=0;memset(child,NULL,sizeof(child));}
}*root;
void Insert(char *s)
{Trie *x=root;int i;for(i=0;s[i];i++){int pos=s[i]-'a';if(x->child[pos]==NULL){x->child[pos]=new Trie;}x=x->child[pos];x->value++;}
}
void DFS(Trie *x,int level)
{if(x==NULL) return;if(x->value==1){ans+=level;return ;}int i;for(i=0;i<=25;i++){if(x->child[i]!=NULL){DFS(x->child[i],level+1);}}
}
int main()
{int t;scanf("%d",&t);while(t--){int n;scanf("%d",&n);ans=0;root=new Trie;int i;for(i=0;i<=n-1;i++){scanf("%s",s);Insert(s);}DFS(root,0);printf("%d\n",ans);}return 0;
}


http://www.ppmy.cn/news/534214.html

相关文章

SpringBoot+JPA整合ShardingShpere实现分表-读写分离

ShardingShpere 分表分库读写分离 ​ ShardingShpere 提供来了根据某个字段分库分表的功能和读写分离。 读写分离 当主服务有写入&#xff08;insert/update/delete&#xff09;语句时&#xff0c;从服务器自动获取。 写入线程从 master 数据库查询查询线程从 salve 数据库…

oracle imp导入dmp文件报12506错误解决办法

通过imp导入数据库dmp文件出错解决办法&#xff1a; IMP-00058: 遇到 ORACLE 错误 12560 ORA-12560: TNS: 协议适配器错误 IMP-00000: 未成功终止导入 遇到这个问题后&#xff0c;很多人会认为是本地服务名的原因&#xff0c;但经过测试&#xff0c;发现服务名是正常的。如果服…

Python知识点复习(一)

问1:f.seek(6, 0)的作用是什么? 答1:将文件对象f的指针从开始的位置偏移到6个字节的位置 拓展: 这是Python中文件操作的一个方法,其中f是一个已经打开的文件对象。该方法的第一个参数表示文件偏移量(offset),即从文件的起始位置开始向后移动的字节数,第二个参数表示偏移…

MySQL - 第7节 - MySQL内置函数

1.日期函数 1.1.常用的日期函数 常用的日期函数如下&#xff1a; 1.2.current_date函数 current_date函数用于获取当前的日期。如下&#xff1a; 1.3.current_time函数 current_time函数用于获取当前的时间。如下&#xff1a; 1.4.current_timestamp函数 current_timestamp函数…

Mysql高级查询语句

数据库是用来存储数据&#xff0c;更新&#xff0c;查询数据的工具&#xff0c;而查询数据是一个数据库最为核心的功能&#xff0c;数据库是用来承载信息&#xff0c;而信息是用来分析和查看的。所以掌握更为精细化的查询方式是很有必要的。本文将围绕数据的高级查询语句展开。…

PID相关参数讲解:1、比例系数Kp与静态误差

PID的结构与公式 来研究静态误差的同学&#xff0c;应该是对PID的原理有一定理解了&#xff0c;简单的概念也不用过多重复。 比例控制时PID控制中最简单的一个&#xff0c;很多能用代码编写PID代码的同学&#xff0c;也不一定理解这个比例系数Kp的意义&#xff0c;以及比例控制…

网络作业10【计算机网络】

网络作业10【计算机网络】 前言推荐网络作业10一. 单选题&#xff08;共13题&#xff0c;68.2分&#xff09;二. 多选题&#xff08;共4题&#xff0c;21.2分&#xff09;三. 阅读理解&#xff08;共2题&#xff0c;10.6分&#xff09; 练习5-39 最后 前言 2023-6-23 15:35:39…

选择进口血糖仪的几个小建议,可收藏

对于买过家用血糖仪的小伙伴一定遇过这样的难题&#xff0c;强生&#xff0c;罗氏&#xff0c;真睿等五花八门的品牌&#xff0c;虹吸式、免调码、滴血式这么多看不懂的名词&#xff0c;真的一秒钟变成选择困难的天秤座啊.... 相信大家在咨询过后一定得知现在选择进口血糖仪的小…