R# setup 运行系统配置会话
R(config)# boot system flash name_of_IOS_file_in_flash 启动时加载闪存中的指定IOS文件
R(config)# boot system tftp IOS_image_name IP_address_of_server 启动时加载TFTP服务器里的IOS文件
R(config)# boot system rom 启动时加载ROM中的迷你IOS文件(启动与这三个命令的顺序有关)
R(config)# config-register 0x hexadecimal_value 改变寄存器的值
rommon 5> confreg 0x2142 2600、3600系列启动后按CTRL-BREAK进入ROMMON模式,改变寄存器的值
R> o/r 0x2142 其他系列路由器改变寄存器的值的方法
**密码设置**
R(config)# line console 0 进入控制台接口配置模式
R(config-line)# password console_password 配置控制台口令
R(config)# line vty 0 4 进入虚拟终端线路配置模式(根据路由器及IOS最少5个直到很多)
R(config-line)# login 接上条命令,允许进行Telnet访问
R(config-line)# password telnet_password 接上条命令,配置Telnet口令
R(config)# line aux 0 进入辅助端口配置模式
R(config-line)# password console_password 接上条命令,配置辅助端口口令
R(config)# enable password privileged_password 配置特权EXEC口令(不加密)
R(config)# enable secret privileged_password 配置特权EXEC口令(加密)
接口配置
R(config)# interface type [slot_#/] port_# 进入接口子配置模式
R(config-if)# description interface_description 添加接口描述
R(config-if)# no shutdown 启用该接口
R(config)# interface loopback port_# 创建环回接口
R(config-if)# media-type aui|10baset|100baset|mii 指定该接口连接的介质类型
R(config-if)# speed 10|100|auto 指定该接口速率
R(config-if)# [no] half-duplex 指定该接口双工模式
R(config-if)# clock rate rate_in_bits_per_second 指定该DCE串行接口速率
R> show controller serial [slot_#/] port_# 验证该接口是DCE还是DTE,注意空格
R(config-if)# bandwidth rate_in_Kbps 改变该接口的带宽值
R(config-if)# ip address IP_address subnet_mask 配置该接口IP地址
R(config)# ip subnet-zero IOS12.0前默认禁用0子网,此命令为启用
R(config-if)# ip directed-broadcast IOS12.0后默认禁用定向广播,此命令为启用
R# show interfaces [type [slot_#/] port_#] 验证接口配置
R# show ip interfaces [type [slot_#/] port_#] [brief] 验证接口IP配置
**CDP**
R(config)# [no] cdp run 启用/禁用CDP
R(config-if)# [no] cdp enable 基于接口启用/禁用CDP
R# show cdp 查看CDP状态
R# show cdp interface 查看基于接口的CDP配置
R# show cdp neighbors [detail] 查看与用户Cisco设备相连的CDP邻居的摘要/详细清单
R# show cdp entry neighbor's_name 查看一个指定邻居的详细信息
R# show cdp traffic 查看CDP通信量的统计信息
路由
R(config)# ip route destination_network_# [subnet_mask] IP_address_of_next_hop_neighbor|interface_to_exit [administrative_distance] [permanent] 配置IP静态路由
R(config)# ip route 0.0.0.0 0.0.0.0 IP_address_of_next_hop_neighbor|interface_to_exit [administrative_distance] [permanent] 配置默认路由
R(config)# ip classless 使有类协议接受非一致性子网掩码或不连续子网
R(config)# interface type [slot_#/] port_#. subinterface_# [point-to-point|multipoint] 创建子接口
R(config-subif)# encapsulation isl|dotlq VLAN_# 指定子接口中继类型和相关的VLAN
R(config)# router name_of_the_IP_routing_protocol 进入路由选择协议的配置模式
R# show ip route 查看IP路由表
**RIP**
R(config)# router rip 配置IP RIP
R(config-router)# network IP_network_# 指定哪些接口参与路由选择进程
R(config-router)# version 1|2 只接受和发送RIP版本1或2(默认只产生RIPv1更新,而两个版本的更新都接收)
R(config-router)# ip rip send|receive version 1 | version 2 | version 1 2 在特定接口上控制在发送或接收RIP更新时使用哪个版本的RIP
R# show ip protocols 查看在路由器上已配置并运行的所有IP路由选择协议
R# show ip route [name_of_the_IP_routing_protocol] 查看路由选择表
R# debug ip rip 帮助进行故障排除
**IGRP**
R(config)# router igrp AS_# 配置IP IGRP
R(config-router)# network IP_network_# 通告网络号
R(config-router)# neighbor IP_address_of_neighbor 配置单播更新
R(config-router)# passive-interface type [slot_#/] port_# 允许该接口在IGRP中通告但它不监听或发送IGRP更新
R(config-router)# traffic-share min across-interfaces 使路由器只使用最佳路径但又在路由选择表中放入替代路径
R(config-router)# timers basic update_# invalid_# holddown_# flush_# [sleeptime_#] 调整定时器(默认时,update=90,invalid=270,holddown=280,flush=630)
R(config-router)# no metric holddown 关闭压制定时器(默认)
R(config-router)# distance administrative_distance_# 调整管理距离(取值范围是1-255,默认为100)
R(config-router)# default-metric bandwidth_# delay_# reliability_# load_# MTU_# 调整度量值
R(config-router)# metric weights tos_# K1_# K2_# K3_# K4_# K5_# 调整度量权重值(默认时,K1(带宽)=K3(可靠性)=1,K2(延迟)=K4(负载)=K5(MTU)=0)
R(config-router)# variance multiplier_# 启用IGRP非同等成本路径(变化因子值1-128默认为1)
R(config-router)# traffic-share balanced 配置负载均衡
R(config-router)# maximum-paths paths_# 配置负载均衡的路径条数(取值范围是1-6)
R# debug ip igrp events 提供路由器和邻居间发生的每一步操作信息
R# debug ip igrp transactions 提供有关包含在路由更新中路由的详细信息
EIGRP
R(config)# router eigrp AS_# 配置EIGRP
R(config-router)# network IP_network_# 通告网络号
R(config-if)# ip bandwidth-percent eigrp AS_# percent_# 设置pacing(调速)占给定接口带宽的百分数(默认为50%)
R(config-router)# distance administrative_distance_# 调整管理距离(取值范围是1-255,默认对于内部路由是90而外部是170)
R(config-router)# default-metric bandwidth_# delay_# reliability_# load_# MTU_# 调整度量值
R(config-router)# metric weights tos_# K1_# K2_# K3_# K4_# K5_# 调整度量权重值(默认时,K1(带宽)=K3(可靠性)=1,K2(延迟)=K4(负载)=K5(MTU)=0)
R(config-if)# ip hello-interval eigrp AS_# seconds_# 在给定接口上设置Hello间隔(默认对于低速的NBMA网络是60秒,其他是5秒)
R(config-if)# ip hold-time eigrp AS_# seconds_# 在给定接口上设置Hello保持定时器(默认是3倍的Hello间隔)
R(config-router)# passive-interface type [slot_#/] port_# 允许该接口在EIGRP中通告但它不监听或发送EIGRP更新
R(config-router)# no auto-summary 取消对路由的自动汇总
R(config-if)# ip summary-address eigrp AS_# network_address network_mask 创建不在有类边界上的汇总地址
R(config)# eigrp log-neighbor-changes 记录在某个邻居上发生的变化
R# show ip route eigrp 查看被EIGRP学习到的路由
R# show ip route network_address 查看指定目的地的路由信息
R# show ip eigrp topology 查看EIGRP的拓扑表
R# show ip eigrp interfaces 查看加入到EIGRP路由器所有接口的概述
R# show ip eigrp neighbor [detail] 显示和本路由器已形成邻居关系的所有路由器
R# show ip eigrp traffic 显示每个包类型的发出和接收的数量
R# show ip eigrp events 查看每个EIGRP事件的日志
R# debug ip eigrp 提供路由器和它的邻居之间发生的每一步操作
R# debug eigrp packets 查看在该路由器和它的邻居之间发送的数据包类型
R# debug eigrp neighbors 查看邻居的信息
OSPF
R(config)# router ospf process_ID 配置OSPF
R(config-router)# network IP_address wildcard_mask area area_# 指定接口进入OSPF区域
R(config-if)# ip ospf cost cost_value 给接口指定成本(取值范围是1-65535)
R(config-router)# neighbor IP_address_of_neighbor 手动配置邻居
R(config-router)# neighbor IP_address_of_neighbor priority value 指定邻居的优先级(取值范围是0-255,255为DR,0为不可能成为DR)
R(config-if)# ip ospf network non-broadcast 手工配置非广播网络类型
R(config-router)# area area_id stub 允许创建存根区域
R(config-router)# area area_id stub no-summary 允许创建完全存根区域
R(config-router)# area area_id nssa 允许创建次存根区域
R(config-router)# area area_id virtual-link router_id 连接不连续区域为骨干区域0
R(config-router)# area area_id range network_address network_mask 在区域边界路由器上汇总在给定区域中的路由器使用的IP地址空间到其他的区域
R(config-router)# summary-address network_address network_mask 在自治系统边界路由器上汇总外部路由
R# show ip ospf 概述所有OSPF相关的信息
R# show ip ospf process-id 与上相同,而不仅仅是指定的进程
R# show ip ospf border-routers 显示在此自治系统中所有ABR和ASBR的路由器ID
R# show ip ospf database 显示链路状态数据库
R# show ip ospf interface 显示接口的OSPF参数和其他的指定到此接口上的OSPF信息
R# show ip ospf neighbor [detail] 显示每个OSPF邻居和邻接状态
R# debug ip ospf adj 报告路由器建立到其他路由器的邻接关系进程
R# debug ip ospf events 报告路由器上的OSPF事件
R# debug ip ospf packet 报告OSPF LSA分组的内容
ACL
R(config)# access-list 1-99|1300-1999 permit|deny source_IP_address [wildcard_mask] [log] 创建标准编号IP ACL
R(config-if)# ip access-group ACL_# in|out 在指定接口上启动ACL
R(config-line)# access-class standard_ACL_# in|out 在指定若干线路上启动ACL以限制对路由器的Telnet访问
R(config)# access-list 100-199|2000-2699 permit|deny IP_protocol source_address source_wildcard_mask [protocol_information] destination_address destination_wildcard_mask [protocol_information] [log] 创建扩展编号IP ACL
R(config)# ip access-list standard ACL_name 创建标准命名ACL(从IOS11.2开始支持)
R(config-std-acl)# permit|deny source_IP_address [wildcard_mask] 输入标准ACL命令
R(config)# ip access-list extended ACL_name 创建扩展命名ACL(从IOS11.2开始支持)
R(config-ext-acl)# permit|deny IP_protocol source_IP_address wildcard_mask [protocol_information] destination_IP_address wildcard_mask [protocol_information] [log] 输入扩展ACL命令
R(config-if)# ip access_group ACL_name in|out 启动命名ACL
R# show ip interfaces 验证访问列表
R# show access-lists [ACL_#_or_name] 显示ACL中的语句
R# show ip access-list [ACL_#_or_name] 显示IP ACL中的语句
R# clear access-list counters [ACL_#_or_name] 对指定ACL中的匹配计数器清零
载分发
R(config)# ip nat inside source static inside_local_source_IP_address inside_global_source_IP_address 定义NAT静态转换
R(config)# ip nat outside source static outside_global_destination_IP_address outside_local_destination_IP_address 定义NAT静态转换
R(config-if)# ip nat inside|outside 指定路由器上哪些接口在内部,哪些在外部
R(config)# ip nat outside source list standard_IP_ACL_# pool NAT_pool_name 为重叠地址转换配置NAT
R(config)# ip nat inside source list standard_IP_ACL_# pool NAT_pool_name 定义动态NAT,指定转换哪些内部设备的源地址
R(config)# ip nat pool NAT_pool_name beginning_inside_global_IP_address ending_inside_global_IP_address netmask subnet_mask_of_addresses|prefix-length length 创建源内部全局IP地址池
R(config)# ip nat inside source list standard_IP_ACL_# pool NAT_pool_name overload 定义PAT,指定哪台内部设备会转换其源地址
R(config)# ip nat pool pool_name beginning_inside_local_IP_address ending_inside_local_IP_address prefix-length subnet_mask_bits type rotary 指定提供服务的设备上配置的内部IP地址
R(config)# ip nat inside destination list standard_ACL_# pool pool_name 指定外部设备用来访问内部资源的全局IP地址
R# show ip nat translations [verbose] 查看路由器上的(详细)地址转换信息
R# show ip nat statistics 查看路由器上的地址转换的统计信息
R# clear ip nat translation * 清除所有NAT表项
R# clear ip nat translation inside|outside global_IP_address|local_IP_address 清除转换表中的指定动态条目
R# clear ip nat translation protocol inside global_IP_address global_port local_IP_address local_port 清除转换表中的指定动态条目
R# debug ip nat 提供IOS对每个已转换分组所做的转换
DHCP
R(config)# [no] service dhcp 启用/禁用DHCP(默认启用)
R(config)# ip dhcp pool pool_name 创建地址池
R(config-dhcp)# network network_number [subnet_mask|/prefix_length] 指定分配给客户的IP地址范围
R(config-dhcp)# domain-name domain_name 向客户分配域名
R(config-dhcp)# dns-server IP_address […] 指定最多8台DNS服务器分配给客户
R(config-dhcp)# netbios-name-server IP_address […] 指定最多8台WINS服务器分配给客户
R(config-dhcp)# netbios-node-type node_type 向微软客户分配节点类型
R(config-dhcp)# default-router IP_address […] 指定最多8条默认路由给客户用于该地址范围
R(config-dhcp)# lease days [hours] [minutes] |infinite 指定租约的期限(默认一天)
R(config)# ip dhcp ping timeout milliseconds 指定测试服务器地址池中的可用地址是否正在使用时服务器应等待时间
R(config)# ip dhcp excluded-address beginning_IP_address [ending_IP_address] 排除一些地址
R(config-if)# ip address dhcp 在路由器上建立DHCP客户
R# show ip dhcp binding [client_address] 查看分配给客户的地址
R# clear ip dhcp binding client_address|* 清除分配给客户的指定/所有地址
R# debug ip dhcp server events|packet|linkage 查看DHCP服务器相关信息
Introduction 介绍 This document lists all the option that is recommended to help you secure your CISCO IOS system devices,which increases the overall security of your network 这篇文档包含了建议你使用的一些安全选项,旨在帮助你加强使用 CISCO IOS 系…