DELL 6248交换机常用配置示例

news/2024/12/14 7:51:05/
  1. 将 running-config 文件保存为 startup-config 文件。这可确保刚刚完成的配置在交换机重新引导后保持不变。

console(config)#exit

console#copy running-config startup-config

此时交换机完成配置,并可通过不同的选项(例如, Telnet、 Web 浏览器界面和其它选项)对其进行管理

1:配置登录用户,口令等 

console>                   //用户直行模式提示符 

console>enable             //进入特权模式 

console#                   //特权模式(配置密码后必须输入密码才可进入特                                                     权模式) 

console#config     //进入全局配置模式 configure 

console(config)#           //配置模式提示符 

console(config)#exit    //还有一个命令是end也和exit差不多 

console#quit 

console>

console(config)#hostname xxx //设置主机名成为xxx这里使用console

console(config)#enable password xxx //设置使能口令为明文显示为xxx,必须不少于8字符远程telnet的时候起作用本地通过console口不需要密码的 

console(config)#username zy password 12345678 level 15 //定义交换机的用户名以及对应的权限。

console(config)#line console  //进入console口配置视图,这里可以设置通过超级终端访问交换机的一些参数 

console(config-line)#enable authentication default //配置访问角色为默认 

console(config-line)#exec-timeout minutes // 设置console口自动关闭时间,以分钟为单位 

console(config-line)#speed 9660  //设置访问速率,一般9660为默认设置。 

console(config-line)#password xxxx //不少于八位的密码用来访问console,与enable password xxx,差不多 

console(config-line)#no password   //删除password密码 

console(config-line)#exit //退出console口配置视图

console(config)#line telnet //进入telnet配置视图 

console(config-telnet)#enable authentication default //配置访问角色为默认 

console(config-telnet)#exec-timeout minutes // 设置telnet访问闲置自动关闭时间,以分钟为单位 

console(config-telnet)#password xxxx //不少于八位的密码用来访问telnet 

console(config-telnet)#no password   //删除password密码 

console(config-telnet)#exit //退出telnet口配置视图

console(config)#line ssh //进入ssh配置视图 

console(config-ssh)#enable authentication default //配置访问角色为默认 

console(config-ssh)#exec-timeout minutes // 设置ssh访问闲置自动关闭时间,以分钟为单位 

console(config-ssh)#password xxxx //不少于八位的密码用来访问ssh 

console(config-ssh)#no password   //删除password密码 

console(config-ssh)#exit //退出ssh口配置视图

2:cisco2960 VLan设置

console> enable              //进入特权模式 

console#configure       //进入配置视图 

console(config)#vlan database        //进入vlan设置 

console(config-vlan)#vlan 2    //创建vlan 2 

console(config-vlan)#no vlan 2   v   //删除vlan 2 

console(config-vlan)#exit            //回到特权模式下

console(config)#interface vlan 2 //进入vlan2配置视图 

console(config-if-vlan2)#name xxx //为vlan取名字

端口设置命令:

console(config)#interface ethernet 1/g1  //进入网口1,/1/g1指的是第一个插槽上的第一个千兆网口 

console(config-if-1/g1)#                         //接口视图模式 

console(config-if-1/g1)#speed 10/100/1000    //定义端口的带宽,只能从这三种模式中做选择。 

console(config-if-1/g1)#duplex full/half    //定义双工模式 

console(config-if-1/g1)#negotiation         //启用自动协商速度和双工参数 

console(config-if-1/g1)#no negotiation      //禁用自动协商速度和双工参数 

console(config-if-1/g1)#switchport mode access/trunk/general //定义端口类型,总共有三种类型 

console(config-if-1/g1)#switchport access vlan 2   //将端口以access模式加入到vlan 2中 

console(config-if-1/g1)#shutdown                 //关闭当前端口 

console(config-if-1/g1)#no shutdown              //打开当前端口

console(config)#interface ethernet 1/g24     //进入汇聚千兆口24,共有4个千兆combo口21-24 

console(config-if-1/g24)#

console(config-if-1/g24)#duplex auto/full/half   //设置端口工作模式为 自适应/全双通/半双通 

console(config-if-1/g24)#switchport mode trunk   //设置当前端口模式为汇聚口 

console(config-if-1/g24)#switchport mode access  //设置当前端口模式为接入模式 

console(config-if-1/g24)#switchport trunk allowed vlan add/remove 1,2 //将当前汇聚端口加入或移除从vlan1,2通过,vlan修剪,默认为all,全部允许 

console(config-if-1/g24)#switchport access vlan 2 //将当前端口以access模式加入到vlan 2中

若21-24号口用作光口的话配置接口就对应1/xg1-1/xg4代表使用光线做10G上联口用:

console(config)#interface ethernet 1/xg1     //进入汇聚万兆口1,共有4个千兆combo口21-24对应四个1/xg1-1/xg4万兆光口

console(config-if-1/xg1)#

console(config-if-1/xg1)#duplex auto/full/half   //设置端口工作模式为 自适应/全双通/半双通 

console(config-if-1/xg1)#switchport mode trunk   //设置当前端口模式为汇聚口 

console(config-if-1/xg1)#switchport mode access  //设置当前端口模式为接入模式 

console(config-if-1/xg1)#switchport trunk allowed vlan add/remove 1,2 //将当前汇聚端口加入或移除从vlan1,2通过,vlan修剪,默认为all,全部允许 

console(config-if-1/xg1)#switchport access vlan 2 //将当前端口以access模式加入到vlan 2中

将端口加入vlan 

console(config)#interface ethernet 1/g1 

console(config-if-1/g1)#switchport mode access 

console(config-if-1/g1)#switchport access vlan 2

将多个端口加入到VLAN中 

console(config)#interface range ethernet 1/g1-1/g12 //进入1-12这个接口组里配置 

console(config-if)#switchport mode access 

console(config-if)#switchport access vlan 2 

console#show vlan   //用于查看配置后结果

3:设置VTP cisco专有的vlan终极协议也成为局域网干道协议,作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息

4:交换机配置IP地址

console(config)#interface vlan 1   //进入vlan 1 

console(config-if-vlan1)#ip address 119.167.223.221 255.255.255.128 //设置交换机的管理ip地址 

console(config)#ip default-gateway 119.167.223.254   //设置交换机的默认网关 

console(config)#end                                //退出当前模式

5: 交换机保存设置命令 

console#copy running-config startup-config //将当前正在使用中的配置保存到交换机开机需要加载的配置文件里去。 

console#copy running-config backup-config //将当前的配置保存在备份配置文件里 

6:交换机显示命令

特权模式下: 

console#show running-config             //显示当前正在使用的配置信息 

console#show startup-config            //交换机开机是自动加载的 配置文件    

console#show vlan                      //显示vlaner配置信息 

console#show interfaces configuration ethernet 1/g1  //显示二层端口状态,可以用来决定此口是否为二层或三层口

console#show ip  interface vlan100      //查看交换机vlan100的ip配置信息 

console#show version                   //查看交换机固件版本信息

7:基于端口的mac地址绑定

console#config               //进入配置视图模式 

console(config)#interface ethernet 1/g1 //进入具体端口视图模式下 

console(config-if-1/g1)#switchport port-secruity  //配置端口安全模式 

console(config-if-1/g1)#switchport port-secruity mac-address MAC(主机的mac地址) //配置该端口要绑定的主机的MAC地址 

console(config-if)#no switchport port-secruity mac-address MAC(主机的mac地址) //删除绑定主机的mac地址

8:配置交换机的snmp功能

console(config)#snmp-server community xxx ro  //xxx为自定义的共同体名称,并且团体的权限为只读。

console(config)#snmp-server host x.x.x.x(ip地址) xxx(团体名)  //设置管理机x.x.x.x,同时允许该管理机以团体明xxx访问。 

console(config)#snmp-server host 119.167.223.221 zy          //例子 

console(config)#snmp-server enable traps   //启用snmp服务

9:交换机禁ping配置

console(config)#access-list 110 deny icmp any any    //配置访问控制列表(Access Control List,ACL)110指的ICMP对应ping。 

console(config)#access-list 110 permit ip any any    //运行所有的IP协议的应用

console(config)#int vlan 1 

console(config-if-vlan1)#ip access-group 110 in

console(config)#int vlan 2 

console(config-if-vlan2)#ip access-group 110 in 

console(config)#int vlan 3 

console(config-if-vlan3)#ip access-group 110 in 

console(config)#interface ethernet 1/g1            //端口禁ping 

console(config-if-1/g1)#ip access-group 110 in

 . 

 .

10:恢复交换机出厂设置

console#clear config //恢复交换机出厂设置 

 console#reload  //重新启动交换机

11: 端口汇聚

console>enable 

console#config 

console(config)#interface ethernet 1/g1 

console(config-if-1/g1)#speed 1000 

console(config-if-1/g1)#duplex full 

console(config)#interface ethernet 1/g2 

console(config-if-1/g2)#speed 1000 

console(config-if-1/g2)#duplex full 

console(config-if-1/g2)#exit 

console(config)#interface range ethernet 1/g1-1/g2 

console(config-if)#channel-group 1 mode on/auto 

console(config-if)#switchport mode trunk 

console(config-if)#switchport trunk allowed vlan all 

console#show etherchannel summary //查看端口汇聚状态。 

另外一台交换机的对应汇聚端口务必要和这里两个汇聚口的设置一样。 

R1#vlan database 

R1(vlan)#vlan 2 

R1(vlan)#exit 

R1#configure terminal 

R1(config)#int range fastethernet 0/1-4 

R1(config-int-range)# switchport access vlan 2 

R1(config-int-range)# channel-group 1 mode on

R2#vlan database 

R2(vlan)#vlan 2 

R2(vlan)#exit 

R2#configure terminal 

R2(config)#int range fastethernet 0/1-4 

R2(config-int-range)# switchport access vlan 2 

R2(config-int-range)# channel-group 1 mode on

同一个vlan里汇聚,端口使用access状态,多个VLAN之间汇聚端口才需要trunk状态。


http://www.ppmy.cn/news/420653.html

相关文章

赛天网吧无盘服务器,200台MZD无盘网吧解决方案.docx

斯普林无盘,网吧的春天 ----自己动手组建一个200台的中型无盘网吧 2006年,网吧产业迎来发展的春天。“吧”风四起,随着网吧行业的不断发展,网吧 的经营者们面临着越来越多崭新的问题。如何能让自己的网吧紧跟市场的需要&#xff0…

啊,第一次月赛天杀的散步题目

00001:郭姐散步 总时间限制: 1000ms 内存限制: 32768kB 描述 The first lady of our lab is GuoJie, GuoJie likes walking very much. Today GuoJie walks from the original point (0, 0), everytime he(may be she?) can go up or left or right a step. But she cant …

Python-天池新人赛天猫优惠券O2O预测数学建模赛

比赛官网:天池新人实战赛o2o优惠券使用预测 O2O(Online to Offline)消费是指将线下的商务机会与互联网结合,让互联网成为线下交易的平台。以优惠券盘活老用户或吸引新客户进店消费是O2O的一种重要营销方式。通过个性化投放优惠券…

赛天服务器主板怎么看型号,赛天EC602服务器RAID组建方法.DOC

赛天E5 RAID组建方法及注意事项说明 目 录 TOC \o "1-3" \h \z \u 一,总述 h 2 二、赛天E5系列PCH LSI RAID组建3 三、赛天E5系列SCU及PCH INTEL RAID组建6 四、赛天E5系列 PIKE 9230 RAID组建方法9 五、9230在WINDOWS操作系统里面的RAID组建方法12 六.注…

赛天服务器怎么做系统,赛天EC602服务器RAID组建方法.doc

赛天E5 RAID组建方法及注意事项说明 目 录 TOC \o "1-3" \h \z \u HYPERLINK 一,总述 2 HYPERLINK 二、赛天E5系列PCH LSI RAID组建3 HYPERLINK 三、赛天E5系列SCU及PCH INTEL RAID组建6 HYPERLINK 四、赛天E5系列 PIKE 9230 RAID组建方法9 五、9230在WINDOWS操作系统…

必学KVM技术详解包括所有技能

KVM虚拟化进阶学习 一,KVM命令行安装 图形化安装教程:https://blog.csdn.net/weixin_53678904/article/details/125950867?spm1001.2014.3001.5501 1.存储池管理 ​ KVM必须要配置⼀个⽬录当作他存储磁盘镜像(存储卷)的⽬录,我们称这个⽬…

MybatisPlus自动填充

当数据类型出现updateuser,createuser等通用字段字段发生更改的时候,我们一般在service层对通用数据进行填充,在MybatisPlus的功能中可以对指定字段进行填充 实体类表明字段 实体类 package com.example.ruiji.Entity;import com.baomidou.mybatisplus.annotation.FieldFill;…

【Elasticsearch】面试题汇总(2023.6)

索引优化思路? ES索引优化主要从两个方面解决问题: 一、索引数据过程 大家可能会遇到索引数据比较慢的过程。其实明白索引的原理就可以有针对性的进行优化。ES索引的过程到相对Lucene的索引过程多了分布式数据的扩展,而这ES主要是用tranlog进…