HDU 2489

news/2024/12/29 12:37:23/

题目:

Minimal Ratio Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 348


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.


 

Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.


 

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .


 

Sample Input
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0


 

Sample Output
  
1 3 1 2


 

Source
2008 Asia Regional Beijing


 

Recommend
gaojie

 

深搜枚举m个点的子图,精度问题害死人。。 判小于的时候要判相减<-(1e-9) 才能对。。

//problem_id hdoj 2489
#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 0x1f1f1f1f
#define MIN(a,b) ((a)<(b)?(a):(b))
#define MAX(a,b) ((a)>(b)?(a):(b))
int edge_wei[20][20];//边权
int node_wei[20];//点权
bool flag[20];
bool fl[20];
double res;
int dfs_cnt;
bool arr[20];//result array
int n,m;
int mst()
{
int ret=0;
int low[20]={0};
int sta;
for(int i=1;i<=n;i++)
{
if(fl[i])
{
sta=i;
break;
}
}
low[sta]=0;
flag[sta]=1;
for(int i=1;i<=n;i++)
{
if(fl[i])
{
low[i]=edge_wei[sta][i];
}
}
for(int i=1;i<m;i++)
{
int min=INF;
int loc;
for(int j=1;j<=n;j++)
{
if(fl[j]&&!flag[j]&&low[j]<min)
{
min=low[j];
loc=j;
}
}
flag[loc]=1;
ret+=low[loc];
for(int j=1;j<=n;j++)
{
if(fl[j]&&!flag[j])
{
if(edge_wei[loc][j]<low[j])
{
low[j]=edge_wei[loc][j];
}
}
}
}
return ret;
}
void dfs(int v)
{
fl[v]=1;
dfs_cnt++;
if(dfs_cnt==m)
{
memset(flag,0,sizeof(flag));
int r=mst();
int sum=0;
for(int i=1;i<=n;i++)
{
if(fl[i])
{
sum+=node_wei[i];
}
}
double res_tmp=(double)r/(double)sum;
if(res_tmp-res<-(1e-9))//精度~~~
{
res=res_tmp;
for(int i=1;i<=n;i++)
{
arr[i]=fl[i];
}
}
fl[v]=0;
dfs_cnt--;
return;
}
for(int i=v+1;i<=n;i++)
{
dfs(i);
}
fl[v]=0;
dfs_cnt--;
}
int main()
{
while(scanf("%d%d",&n,&m),n||m)
{
for(int i=1;i<=n;i++)
{
scanf("%d",&node_wei[i]);
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
scanf("%d",&edge_wei[i][j]);
}
}
res=(double)INF;
for(int i=1;i<=n-m+1;i++)
{
memset(fl,0,sizeof(fl));
dfs_cnt=0;
dfs(i);
}
int fir=1;
for(int i=1;i<=n;i++)
{
if(arr[i])
{
if(fir)
{
fir=0;
printf("%d",i);
}
else
{
printf(" %d",i);
}
}
}
printf("\n");
}
return 0;
}


 

 


http://www.ppmy.cn/news/294399.html

相关文章

2896

病毒侵袭 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4441 Accepted Submission(s): 1138 Problem Description 当太阳的光辉逐渐被月亮遮蔽&#xff0c;世界失去了光明&#xff0c;大地迎来最黑暗的时刻…

hdu 2098

分拆素数和 Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 14023 Accepted Submission(s): 6023 Problem Description 把一个偶数拆成两个不同素数的和&#xff0c;有几种拆法呢&#xff1f; Input 输入包含…

2299

这道题目的大意 是求 冒泡排序的交换次数 但是 若这道题目 用冒泡排序做的话&#xff0c;肯定会超时 。O(n^2); 但这道题目可以转换为求 逆序数 的大小。&#xff08;线性代数里面学过的&#xff09; 9 1 0 5 4 逆序数41016 这正是 答案。 我们可以使用 merge_sort() 来…

p2249

二分查找stl #include<iostream> #include<vector> #include<algorithm>using namespace std;int main() {int n, m, temp_number, temp_search; // n 和 m&#xff0c;表示数字个数和询问次数。vector<int> number;vector<int> search;cin…

【服务器】常用命令汇总

查看当前使用服务器的用户 命令&#xff1a; w 使用w命令查看登录用户正在使用的进程信息 参考&#xff1a;https://blog.csdn.net/newdriver2783/article/details/8059368 修改服务器主机名hostname 查看主机名的命令 hostname 临时修改Linux主机名的方法 hostname linux…

【ELMAN回归预测】基于matlab麻雀搜索算法SSA优化ELMAN神经网络回归预测(多输入单输出)【含Matlab源码 2489期】

⛄一、麻雀算法简介 1 标准麻雀算法 算法运算过程由探索者、追随者与预警者3部分构成&#xff0c;其中探索者与追随者的总数量与比例不变&#xff0c;根据适应度数值的改变&#xff0c;两者可以相互转化。通过觅食和反捕食行为来不断更新种群成员最优位置。 设种群数量为n,在…

vue-router 4.0.xx 控制台 api.now is not a function 的解决方法

vue-router 4.0.xx 控制台 api.now is not a function 的解决方法 **摘要&#xff1a;**控制台报错 Uncaught (in promise) TypeError: api.now is not a function at vue-router.esm-bundler.js:2489:31 at vue-router.esm-bundler.js:3296:37 at Array.forEach () at trigge…

WuThreat身份安全云-TVD每日漏洞情报-2022-12-27

漏洞名称:Oracle WebLogic Server Core 远程代码执行 漏洞级别:严重 漏洞编号:CVE-2020-14825,CNVD-2020-60125,CNNVD-202010-1006 相关涉及:Oracle Oracle WebLogic Server Core 12.1.3.0.0 漏洞状态:POC 参考链接:https://tvd.wuthreat.com/#/listDetail?TVD_IDTVD-2020-164…