工作以来也没有笔记的习惯,总是用到哪就差到哪,感觉很浪费时间。尤其是网络配置这一块,配置完了基本上就不动了,时间一长就完了怎么配置了。现在感觉公司网络经过路由器后网速变慢,打算重新配置下。
第一:配置外网接口IP地址
easytouch(config)#int f0/0
easytouch(config-if)#ip add 58.56.152.100 255.255.255.252
easytouch(config-if)#no sh
第二:配置内网接口IP地址
easytouch(config)#int f0/1
easytouch(config-if)#ip add 192.168.10.1 255.255.255.0
easytouch(config-if)#no sh
第三:网络地址转换
easytouch(config)#int f0/1
easytouch(config-if)#ip nat inside
easytouch(config)#int f0/0
easytouch(config-if)#ip nat outside
第四:配置访问控制列表,指出哪些地址可以转换成外网地址
easytouch(config)#access-list 10 permit 192.168.10.0 0.0.0.255
easytouch(config)#ip nat inside source list 10 interface f0/0 overload
第五:配置默认路由,指出网关的下一跳
easytouch(config)#ip route 0.0.0.0 0.0.0.0 58.56.152.100
第六:配置telnet远程登录
easytouch(config)#username easytouch secret yourpass
easytouch(config)#line vty 0 4
easytouch(config-line)#login local
第七:配置特权密码
easytouch(config)#enable secret yourpass
第八:配置DHCP
easytouch(config)#ip dhcp pool 10
easytouch(dhcp-config)#network 192.168.10.0 255.255.255.0
easytouch(dhcp-config)#default-router 192.168.10.1
easytouch(dhcp-config)#dns-server 192.168.10.200 219.147.1.66
第九:不参与分配的IP地址
easytouch(config)#ip dhcp excluded-address 192.168.10.200 192.168.10.254
第十:端口映射
ip nat inside source static tcp 192.168.10.200 3389 58.56.152.100 8010 extendable